2ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

NiVE愛用者スレ8【NicoVisualEffects】

1 :名無しさん@お腹いっぱい。:2010/03/25(木) 23:03:15 ID:/FeZPLKt0
フリーのモーショングラフィックスソフト、NiVE(NicoVisualEffects)について意見交換するスレです。

NiVEは現在、ver 1.x系と、ver 2.x系の2種類が存在します。
(ver 2.x系は開発中であり、現在α版がリリースされています。)

NicoVisualEffects ホーム(公式サイト)
 ttp://nive.jp/

NiVE@避難所Wiki (解説やサンプル動画がまとめられています)
 ttp://www5.atwiki.jp/nicoae

前スレ:
NiVE愛用者スレ7【NicoVisualEffects】
http://pc12.2ch.net/test/read.cgi/streaming/1265737900

■次スレは>>980の人。立てられない場合は次の担当者をレス番で指定。代理ならスレ内で宣言を。

666 :名無しさん@お腹いっぱい。:2010/10/10(日) 23:38:29 ID:B2Ku84wR0
本体:NiVE2β4(32ビット版) ←AnyCPU版でも試しましたが同じでした
環境:Windows7 64ビット

『StandardMediaInput』で読み込んだWAVEファイルが、VFWOutput等で出力(形式問わず)した後に正常に再生されません。
他の環境の人でも同じ症状が起きるのか気になったのでこちらに書き込んでみます。

読み込んだのはニコニ・コモンズの『【東方】ピチューン音』(ttp://www.niconicommons.jp/material/nc899)です。
言葉で説明しにくいですが、後半部分が最初に再生された後に前半部分が再生されるような感じになってしまいます。
サンプルレートのせいかと思いNiVE2標準の【48kHz、16bit、ステレオ】にリサンプリングしてみましたが、症状変わらずでした。

『AviUtl入力プラグイン利用』の方を使って読み込めば正常に再生されるため、自分で動画を作る分には支障ありません。
ただ今回は作ったプロジェクトファイルをサンプルとして配布したいと思っているため、
誰でも開けるように標準の『StandardMediaInput』で読む必要があり、困っています。

差し当たって、NiVE2本体のせいなのか私の環境(64ビットOS)のせいなのかを切り分けたいので、
どなたか同じ事を試してみてくれませんでしょうか。

667 :名無しさん@お腹いっぱい。:2010/10/11(月) 01:02:29 ID:w9tgvCvO0
>>666
NiVE2β4 XP SP3 32bit環境で同じ症状でした。リサンプリングはしてません。
プラグイン開発感謝です。

668 :名無しさん@お腹いっぱい。:2010/10/11(月) 04:39:30 ID:mGpbuvgF0
>>667
試していただきありがとうございます。
XPの32ビット環境でも起きるということは『StandardMediaInput』自体の問題のような気がします。

あれから調べたところ、再生時間が約1.2秒以下のWAVEだとこの症状が起きるようです。
元ファイルのサンプルレートは関係なくこの時間です(44.1kHzと48kHzしか試してないですが)。
※AviUtlで36フレーム分WAV書き出し→症状発生
※AviUtlで37フレーム分WAV書き出し→正常に再生される

で、本家のバグ報告を検索したら7カ月前に報告されているようでした。
http://nive.jp/NiVE2/index.php?%A5%D0%A5%B0%CA%F3%B9%F0#y747d481
mes氏は32ビット版を使えば回避できると答えているようですが、出力&再生確認はしてない…かも?

とりあえず、ここまでの内容を含めて再度バグ報告しておこうと思います。

331 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.01.03 2014/02/20 Code Monkey ★
FOX ★ DSO(Dynamic Shared Object)